Support Forums

There is a new way to get support - via the support tab in your account.

Our support systems are changing, for the better. You'll be able to manage all your support requests from your account, and respond to any tickets via email.

These support forums are now closed - existing tickets will be closed after a month.

Support Forums Forums Search & Filter Pro WPML Filters

Tagged: ,

Viewing 10 posts - 1 through 10 (of 38 total)
  • Juan Manuel Pérez Álvarez
    #274039

    Hi

    I’m trying to setup pretty simple filtering on post type archive.
    I’m using ACF Post Meta dropdowns (Radio button and Post Object).
    In main language works fine, but when I’m trying to translate (using https://searchandfilter.com/documentation/3rd-party/wpml/) I’m running into couple problems I am hoping you could help me out with.

    Radio button: dropdown in second language shows main language options.
    Post Object: Although, while I edited the post, I have selected the Post Object in the correct language, it shows it to me in the main one. Also the dropdown is populated by the results of both languages (in both pages).

    It seems S&F is not showing the correct language on fields.

    I have tried rebuilding the cache and and re-enabling the plugin with no luck.
    I have also checked the ACF custom field settings with “Advanced Custom Fields Multilingual Plugin”.

    This support thread is similar: https://support.searchandfilter.com/forums/topic/problems-with-sf-and-polylang/ but I can’t get it to work.

    Any ideas?

    Thank you,

    regards,

    Trevor Moderator
    #274064

    In the Search & Filter plugin settings (NOT in a form itself) do you have the use transients setting enabled?

    This does not work yet with WPML (we didn’t integrate language parameters into this feature).

    Unless you’re hitting high numbers I think you will be ok with this setting disabled.

    Juan Manuel Pérez Álvarez
    #274178

    Hi Trevor,

    I don’t have use transients setting enabled.

    Thanks

    Trevor Moderator
    #274180
    This reply has been marked as private.
    Juan Manuel Pérez Álvarez
    #274191
    This reply has been marked as private.
    Trevor Moderator
    #274193
    This reply has been marked as private.
    Juan Manuel Pérez Álvarez
    #274414
    This reply has been marked as private.
    Trevor Moderator
    #274435
    This reply has been marked as private.
    Trevor Moderator
    #274467

    I cannot see anything obviously wrong with the form setup. Did you correctly translate that custom field in WPML? That is the only reason I can think might be the cause. I don’t know if it helps, but I did find this documentation:

    https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

    Juan Manuel Pérez Álvarez
    #274528

    Hi Trevor,

    I’ve fixed errors… I was using old ACF fields. Now is almost working fine.
    “type” Dropdown (Radio button ACF field) I’m using “Manual Entry” options
    “Work” Dropdown (Post Object ACF field) still is populated by both languages and I can’t use “Manual Entry”.

    Any ideas?

    Thanks

Viewing 10 posts - 1 through 10 (of 38 total)

You must be logged in to reply to this topic.