Support Forums

Support Forums Forums Search & Filter Pro Pagination not working once Ajax is turned on

This topic is: resolved

This topic contains 6 replies, has 2 voices, and was last updated by  Mardi Lowe 2 days, 19 hours ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Mardi Lowe
    #213945

    Hello,

    As soon as I turn Ajax on the pagination stops working.
    Eg if you select baseplates on this page with Ajax on http://dev.metforcesydney.com.au/product-category/hardware?_sft_pa_hardware=baseplates the pagination stays at 15 pages and the links don’t work. If you turn Ajax off the pagination will show 2 pages available and will successfully click through to the second page.

    Trevor Moderator
    #213949
    This reply has been marked as private.
    Mardi Lowe
    #214251

    Hi Trevor,

    Yes I was using WP PageNavi. Does Search & Filter clash with this?

    Trevor Moderator
    #214257

    It should not, be maybe the implementation is not quite right, which is why I asked if you deactivated WP PageNavi (and removed its code), does pagination work?

    Mardi Lowe
    #214402

    Hi Trevor,

    Yes it works when I remove WP Page Navi.
    Can we get it to work with WP Page Navi or am I best not to use it?

    Trevor Moderator
    #214445

    What happens if you set the Ajax Container to .woocommerce.et_pb_blog_grid_wrapper instead?

    Mardi Lowe
    #214669

    This has done the trick. Thank you!

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Pagination not working once Ajax is turned on’ is closed to new replies.