Support Forums

Support Forums Forums Search & Filter Pro Have to refresh the page to display correct number of results

This topic is: resolved

This topic contains 3 replies, has 2 voices, and was last updated by  Christian Thorne 1 week, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Christian Thorne
    #201921

    Hello,

    This is a strange one… If I select a category with say 3 items, it displays 6, but if I refresh the page it shows the correct number, 3 etc.

    I have delted categories, re-installed them, deleted then created new posts, no luck..

    I checked how the filter was setup and all I could find were the following.

    https://www.screencast.com/t/MqXEmQwB5wn
    https://www.screencast.com/t/BmKPfQWTot

    Any ideas, thanks.

    Christian Thorne
    #201934

    Sorry forgot to include the URL.

    http://mediaworldwide.co.uk/perfect-storm/ams-test-site/news/

    Thanks

    Trevor Moderator
    #201952

    To answer some of the questions. No, the shortcode does not need to be there twice. The second one should be:

    [searchandfilter id="15924" action="filter_next_query"]

    The Ajax Container may indeed need to be:

    .search-filter-results or .search-filter-results-13730

    BUT, why are you using two different sets of ID numbers?

    Christian Thorne
    #201980

    I’ve fixed the issue by duplicating the filter on the case study page.

    You may have seen two different numbers as I was making the change/testing.

    Thanks.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Have to refresh the page to display correct number of results’ is closed to new replies.