Support Forums

Support Forums Forums Search & Filter Pro Custom Post Type Results

This topic is: not resolved
Viewing 8 posts - 1 through 8 (of 8 total)
  • Andrew Smith
    #233818

    Hi there!

    We have the filter set up and it’s working, however it always refreshes to a new page when selecting an item even though Ajax has been selected. Also, when visiting the initial page to list the custom post types, there is no initial search of all the posts.

    We are using Avada and have followed the FAQ’s. We are trying to load the AJAX results into a custom text block with the ID of #searchresults.

    Any help with this issue would be greatly appreciated!

    TIA!

    Trevor Moderator
    #233843

    Are you able to send me a live link/URL to your search page so I can take a look?

    Andrew Smith
    #233867
    This reply has been marked as private.
    Trevor Moderator
    #233955
    This reply has been marked as private.
    Andrew Smith
    #233998
    This reply has been marked as private.
    Trevor Moderator
    #234067

    The forms have an identical appearance? Although, I do see one is using the Shortcode method, and the other uses the As an Archive method.

    The shortcode method will yield results but their appearance is not as desired.

    The as an archive method will not stay on the page (unless you set the page slug as desired, but cannot act upon the Avada archive code, as we have no means (at this time) to connect to their query method.

    The only alternative is to use a third party plugin to do the filtering and styling the display, using this method:

    https://searchandfilter.com/documentation/3rd-party/post-grid/

    Andrew Smith
    #234108
    This reply has been marked as private.
    Trevor Moderator
    #234120

    Any help, guidance and snippets you can provide would be of great help, thanks. If it all works now, can I close this thread?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.