Blog post is not showing

Forums › Forums › Search & Filter Pro › Blog post is not showing

Viewing 10 posts – 21 through 30 (of 30 total)
  • Ross Moderator
    #264263
    This reply has been marked as private.
    Anonymous
    #264795
    This reply has been marked as private.
    Ross Moderator
    #264963
    This reply has been marked as private.
    Anonymous
    #265480
    This reply has been marked as private.
    Ross Moderator
    #266175
    This reply has been marked as private.
    Anonymous
    #267415

    Hey Ross,
    This is the host speaking. I have an entry from the error log that shows the possible cause:
    [Fri Nov 20 00:39:43.031216 2020] [proxy_fcgi:error] [pid 11439] [client 209.225.141.228:60831] AH01071: Got error ‘PHP message: WordPress database error Not uniqu
    e table/alias: ‘PMWPAC3’ for query SELECT rac_posts.* FROM rac_posts LEFT JOIN rac_term_relationships ON (rac_posts.ID = rac_term_relationships.object_id) LEFT
    JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND PMWPAC3.meta_key = ‘_wpac_show_in_search’ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id = rac_pos
    ts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN rac_postmeta PMWPAC2 ON PMWPAC2.post_id = rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_on
    ly’ LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND PMWPAC3.meta_key = ‘_wpac_show_in_search’ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id
    = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN rac_postmeta PMWPAC2 ON PMWPAC2.post_id = rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_non
    members_only’ WHERE 1=1 AND ( \n rac_term_relationships.term_taxonomy_id IN (48)\n) AND rac_posts.post_type = ‘search-filter-widget’ AND ((rac_posts.post_sta…
    \nPHP message: WordPress database error Not unique table/alias: ‘PMWPAC3’ for query SELECT rac_posts.* FROM rac_posts LEFT JOIN rac_term_relationships ON (rac_p
    osts.ID = rac_term_relationships.object_id) LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND PMWPAC3.meta_key = ‘_wpac_show_in_search’ LEFT JOI
    N rac_postmeta PMWPAC ON PMWPAC.post_id = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN rac_postmeta PMWPAC2 ON PMWPAC2.post_id = rac_posts.
    ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_only’ LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND PMWPAC3.meta_key = ‘_wpac_show_in_search
    ‘ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN rac_postmeta PMWPAC2 ON PMWPAC2.post_id =
    rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_only’ WHERE 1=1 AND ( \n rac_term_relationships.term_taxonomy_id IN (48)\n) AND rac_posts.post_type = ‘
    search-filter-widget’ AND ((rac_posts.post_sta…\nPHP message: WordPress database error Not unique table/alias: ‘PMWPAC3’ for query SELECT rac_posts.ID FROM rac
    _posts LEFT JOIN rac_term_relationships ON (rac_posts.ID = rac_term_relationships.object_id) LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND
    PMWPAC3.meta_key = ‘_wpac_show_in_search’ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN ra
    c_postmeta PMWPAC2 ON PMWPAC2.post_id = rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_only’ LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_pos
    ts.ID AND PMWPAC3.meta_key = ‘_wpac_show_in_search’ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LE
    FT JOIN rac_postmeta PMWPAC2 ON PMWPAC2.post_id = rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_only’ WHERE 1=1 AND ( \n rac_term_relationships.term_
    taxonomy_id IN (48)\n) AND rac_posts.post_type = ‘search-filter-widget’ AND ((rac_posts.post_st…\nPHP message: WordPress database error Not unique table/alias: ‘
    PMWPAC3’ for query SELECT rac_posts.ID FROM rac_posts LEFT JOIN rac_term_relationships ON (rac_posts.ID = rac_term_relationships.object_id) LEFT JOIN rac_term_
    relationships AS tt1 ON (rac_posts.ID = tt1.object_id) LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND PMWPAC3.meta_key = ‘_wpac_show_in_searc
    h’ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN rac_postmeta PMWPAC2 ON PMWPAC2.post_id =
    rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_only’ LEFT JOIN rac_postmeta PMWPAC3 ON PMWPAC3.post_id = rac_posts.ID AND PMWPAC3.meta_key = ‘_wpac_sho
    w_in_search’ LEFT JOIN rac_postmeta PMWPAC ON PMWPAC.post_id = rac_posts.ID AND PMWPAC.meta_key = ‘_wpac_is_members_only’ LEFT JOIN rac_postmeta PMWPAC2 ON PMWPAC2
    .post_id = rac_posts.ID AND PMWPAC2.meta_key = ‘_wpac_is_nonmembers_only’ WHERE 1=1 AND ( \n rac_term_relationships.term_taxonomy_id IN (48)…\n’, referer: htt
    ps://www.reflexologycanada.org/en/webinars/

    This suggests that there is an error in the query. Please advise.

    Anonymous
    #267417

    I also see other errors that seem to include PHP errors in the theme. Searching for this error on google suggests a PHP version issue. This site is running PHP 7.2 at this time.

    Ross Moderator
    #268004

    Hi there

    I think we’ve been getting a bit confused, as I am currently unable to replicate your site.

    Earlier on in this chain, it was discussed that I need to disable things in order to test where the issues can come from.

    As you have a live site, and were unable to copy this somewhere, it was decided I would take a copy of your site, and install it on my computer.

    Right now I am unable to do this because I do not have a copy of the website database.

    The website database, is a database that is installed with every WordPress website – it contains the users yes, but also all the posts, settings, plugin + theme data that are on the site.

    Once I have the database (I have the files, because you gave me FTP access) I can finish recreating the site on my machine.

    The database is something you can get from your hosting control panel, or speak with them directly – then you can just send me the file (something like “database-name.sql” or a zip file) and I will be able to continue.

    Thanks for your continued efforts, those error messages should be helpful when I get to tracking this down.

    If you are unclear on any of the above, please ask, I am here to help.

    Best

    Anonymous
    #268096
    This reply has been marked as private.
    Ross Moderator
    #268761
    This reply has been marked as private.
Viewing 10 posts – 21 through 30 (of 30 total)

Search & Filter Support
Privacy Overview

This website uses cookies so that we can provide you with the best user experience possible. Cookie information is stored in your browser and performs functions such as recognising you when you return to our website and helping our team to understand which sections of the website you find most interesting and useful.

We also use cookies to store items in your cart as well as allowing your to login on the site.

You can adjust all of your cookie settings by navigating the tabs on the left hand side.

By continuing to use this site, you also agree to our Privacy Policy.