Problem when trying to activate plugin

Forums › Forums › Search & Filter Pro › Problem when trying to activate plugin

Viewing 9 posts – 1 through 9 (of 9 total)
  • Anonymous
    #47400

    Hi there,

    Plugin is installed on a multi-site, but trying to activate it, I am receiving the following error:

    [03-Jun-2016 11:40:35 UTC] WordPress-Datenbank-Fehler Index column size too large. The maximum column size is 767 bytes. für Abfrage CREATE TABLE wp_63_search_filter_cache (
    id bigint(20) NOT NULL AUTO_INCREMENT,
    post_id bigint(20) NOT NULL,
    post_parent_id bigint(20) NOT NULL,
    field_name varchar(255) NOT NULL,
    field_value varchar(255) NOT NULL,
    field_value_num bigint(20) NULL,
    field_parent_num bigint(20) NULL,
    term_parent_id bigint(20) NULL,
    PRIMARY KEY (id),
    KEY field_name_index (field_name),
    KEY field_value_index (field_value),
    KEY field_value_num_index (field_value_num)
    ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci von activate_plugin, do_action(‘activate_search-filter-pro/search-filter-pro.php’), call_user_func_array, activate_search_filter, Search_Filter_Activator->activate, Search_Filter_Activator->db_install, dbDelta

    Thanks for any insights in how to fix this!

    Thanks and best wishes!

    Trevor
    #47402

    Hi Anna

    This is an InnoDB error from your server, which is most odd. Are you trying to network activate it or activate it on one site?

    Anonymous
    #48158

    Thanks Trevor,

    Trying to activate it on a WordPress multisite, so first network activating it. Don’t I have to do this in order to use it on one WordPress instance? Just planning to use it on one site ;)….

    Thanks for any help!

    Trevor
    #48163

    It should, I think, be installed at network level but NOT network activated. Then in each site (in your case just the one), you need to activate it.

    Anonymous
    #48268

    Hi again Trevor,

    Thanks for your feedback!

    I just activated it for the single WordPress-Instance (not at network level), but I get then the following notice at the top of the Dashboard:

    Search & Filter Error: The caching tables are missing – click here to create them

    If I then click to create them, I end up on a blank page with the error notice in the log, saying: “Index column size too large“…

    Hope we find a solution to get this solved 🙂

    Thanks for any help!

    Trevor
    #48277

    This has to be a server setup issue. I would a lot more information about the server, but I suspect that Ross may need to take a look.

    Anonymous
    #48289

    Thanks – do you think it the error might be related to the innodb_large_prefix option? Maybe you or someone else has come across something similar. Thanks!

    Trevor
    #48296

    Hi

    Is the server a dedicated or VPS and who is the host?

    Trevor
    #49320

    Hi

    A (kind) user posted a note on Twitter regarding this thread.

    Check out the comments on twitter from Justin Mazzi –

    https://twitter.com/jmazzi/status/743116381185576960
    https://twitter.com/jmazzi/status/743116653764960256

    Maybe this is affecting you? It was a bit above my head.

Viewing 9 posts – 1 through 9 (of 9 total)

Search & Filter Support
Privacy Overview

This website uses cookies so that we can provide you with the best user experience possible. Cookie information is stored in your browser and performs functions such as recognising you when you return to our website and helping our team to understand which sections of the website you find most interesting and useful.

We also use cookies to store items in your cart as well as allowing your to login on the site.

You can adjust all of your cookie settings by navigating the tabs on the left hand side.

By continuing to use this site, you also agree to our Privacy Policy.