Support Forums

Support Forums Forums Search & Filter Pro Filters are displayed correctly, but they have no effect on product selection

This topic is: not resolved
Viewing 4 posts - 1 through 4 (of 4 total)
  • Thomas
    #238007

    Hello,

    My configuration:
    – WordPress 5.3.2
    – Astra theme (child)
    – Elementor v2.9.7 (basic version)
    – Woocommerce 4.0.1

    I used a shortcode and I managed to place two filters for a product page:
    – Taxonomy with a Checkbox (the data is detected correctly)
    – Post Meta with a Range-dropdown (data is also detected well)

    Filters are displayed correctly on the page, but they have no effect on product selection. I click on it (after updating and refreshing the page, of course) and nothing happens.

    I must say that I only used the shortcode called “Search Form Shortcode”. Because by using the other two it displayed the wrong products and distorted the product images.

    Thanks for your help. Sorry for the translation errors, I’m French, I do my best

    Trevor Moderator
    #238062

    Are you able to send me a live link/URL to your search page so I can take a look?

    Thomas
    #238070
    This reply has been marked as private.
    Trevor Moderator
    #238118

    Ah, you have two forms on the page. Instead, you need one form with both controls in. If you wish the fields to be horizontal, see here:

    https://searchandfilter.com/documentation/getting-started/display-search-form/#making-your-search-form-horizontal

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.