Support Forums

Support Forums Forums Search & Filter Pro FILTER BUG: Result not showing first time

This topic is: resolved

Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Rob Abrahams
    #262878

    Hi,

    On my website https://paperwise.eu/shop/ is the filter not working correctly.
    If you visit the page and choose/check the “VEL AFMETING BXL IN MM” checkbox once.
    Then you are redirected to the top of the page, but the filter doesn’t load any results. And there is also no search query in the URL bar.

    But if you select another option after that, then the search works fine.

    Any idea?

    Trevor Moderator
    #262881

    I tried what you said and picked a value in that field, shown here in this screenshot:

    https://www.screencast.com/t/628SjOGRLkG

    But, the results refreshed and showed 3 products, first time:

    https://www.screencast.com/t/628SjOGRLkG

    Rob Abrahams
    #262927

    Hi Trevor,

    Look at my screen recording: https://streamable.com/k5o62p

    I don’t know why we experience this issue.
    I use Google Chrome and I have no Javascript errors.

    What do you think? And which browser did you use?

    Trevor Moderator
    #262929
    This reply has been marked as private.
    Rob Abrahams
    #262998
    This reply has been marked as private.
    Trevor Moderator
    #263051

    Thanks. If you disable Auto Count, and return the pagination to Normal, does this still happen? If it does, could you try installing this plugin:

    https://wordpress.org/plugins/enable-jquery-migrate-helper/

    Rob Abrahams
    #263159

    Hi Trevor,

    The plugin didn’t work.

    But I created a solution, since it worked the second check.

    So this is my solution 🙂

    jQuery(document).ready(function(){

    jQuery(‘body’).on(‘click’, ‘.sf-input-checkbox’ function(){
    setTimeout(function(){
    jQuery(this).trigger(‘change’);
    }, 1000);
    });

    });

    Rob Abrahams
    #263161

    Oh I forgot a comma:

    jQuery(document).ready(function(){
     jQuery('body').on('click', '.sf-input-checkbox', function(){
      setTimeout(function(){
       jQuery(this).trigger('change');
      }, 1000);
     });
    });
    Trevor Moderator
    #263164

    Thanks for sharing. Is it OK for me to close this thread for now?

    Rob Abrahams
    #263171

    Yes, it’s good now.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘FILTER BUG: Result not showing first time’ is closed to new replies.