Support Forums

Support Forums Forums Search & Filter Pro Field relationships: "OR" shows 0 hits instead of 10 (Data is coming from pods)

This topic is: resolved

This topic contains 2 replies, has 2 voices, and was last updated by  Trevor 4 days, 11 hours ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • uwe schmelzer
    #221006

    Hi,

    My example page
    ===============
    http://peopleandjobs.wertmacher-projekte.com

    My problem
    ==========
    If i check the boxes
    [x] China (1)
    [x] Deutschland (9)
    i expect 10 hits in the search result.
    Instead i get 0 hits.

    My wp login
    ===========
    http://peopleandjobs.wertmacher-projekte.com/wp-login.php
    USER
    ************

    PASS
    ************

    My configuration
    ================

    1. My Search and Filter-Page
    http://peopleandjobs.wertmacher-projekte.com/

    2. My search and filter settings
    General Tab > Field relationships: OR
    (Makes no difference, if i set it to AND)

    2. MY data to be filtered is coming from this pod:
    jobspod

    3. The fields to be filtered are of pods fieldtype “simple relations”:
    – level
    – bu
    – land

    Cheers
    uwe

    uwe schmelzer
    #221007

    Oh, found the solution myself:
    Go to WP-Backend > Search & Filter > Edit my filter

    Then:
    Settings & Defaults > Field relationships: OR
    Search Form UI > My Field1 > Search operator: OR
    Search Form UI > My Field2 > Search operator: OR
    Search Form UI > My Field3 > Search operator: OR

    Have a nice weekend
    uwe

    Trevor Moderator
    #221064

    Great to hear you got it sorted. I will close this thread for now.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Field relationships: "OR" shows 0 hits instead of 10 (Data is coming from pods)’ is closed to new replies.